
Illustrator / Creating text 

Enter text at a point 

Point type is a horizontal or vertical line of text that begins where you click and expands as 
you enter characters. Each line of text is independent—the line expands or shrinks as you 
edit it, but doesn’t wrap to the next line. Entering text this way is useful for adding a few words 
to your artwork. 

1. Select the Type tool  or the Vertical Type tool . 

The pointer changes to an I-beam within a dotted box. The small horizontal line near 
the bottom of the I-beam marks the position of the baseline, on which the text rests. 

2. (Optional) Set text-formatting options in the Control panel, Character panel, or 
Paragraph panel. 

3. Click where you want the line of text to begin.  

Important: Be sure not to click an existing object, because doing so converts the type 
object into area type or type on a path. If an existing object is located where you want 
to enter text, lock or hide the object. 

4. Enter the text. Press Enter or Return to begin a new line of text within the same type 
object. 

5. When you finish entering text, click the Selection tool  to select the type object. 
Alternatively, Ctrl-click (Windows) or Command-click (Mac OS) the text. 

Enter text in an area 

Area type (also called paragraph type) uses the boundaries of an object to control the flow of 
characters, either horizontally or vertically. When the text reaches a boundary, it automatically 
wraps to fit inside the defined area. Entering text this way is useful when you want to create 
one or more paragraphs, such as for a brochure. 

1. Define the bounding area: 

o Select the Type tool  or the Vertical Type tool , and drag diagonally to 
define a rectangular bounding area.  

o Draw the object you want to use as the bounding area. (It doesn’t matter if 
the object has stroke or fill attributes, because Illustrator automatically 

removes them.) Then select the Type tool , the Vertical Type tool , 

the Area Type tool , or the Vertical Area Type tool and click 
anywhere on the object’s path.  



 

Creating a type area by dragging (top) compared to converting an existing 
shape to a type area (bottom)  

Note: If the object is an open path, you must use the Area Type tool to define 
the bounding area. Illustrator draws an imaginary line between the endpoints 
of the path to define the boundaries. 

2. (Optional) Set text-formatting options in the Control panel, Character panel, or 
Paragraph panel. 

3. Enter the text. Press Enter or Return to begin a new paragraph. 

4. When you finish entering text, click the Selection tool  to select the type object. 
Alternatively, Ctrl-click (Windows) or Command-click (Mac OS) the text.  

If you enter more text than can fit within an area, a small box containing a plus 
symbol (+) appears near the bottom of the bounding area.  



 

Example of overflow text 

You can resize the text area or extend the path to display the overflow text. You can 
also thread the text into another object. 

Manage the text area 

Resize a text area 

You can resize text in different ways, depending on the whether you are creating point type, 
area type, or text along a path.  

There is no limit for the amount of text that can be written using point type, so resizing of the 
text box is not required in this case. 

When using the area type tool, you drag an object and type inside the selected area. In this 
case, the text resizes when you resize the object using the Direct Selection tool. 

When you type text along a path, you can thread text between objects (see Threading text 
between objects), if the text does not fit in the selected path. In this case also, the text is 
resized if you resize the path using the Direct Selection tool. 

Make sure that the bounding box setting is set to Show Bounding Box. If you are not able 
to see the bounding box, then click View > Show Bounding Box. 

 To resize, do one of the following: 

• Select the type object using the Selection tool or Layers panel, and drag a handle on 
the bounding box.  



 

Resizing a text area with the Selection tool 

• Select the edge or corner of the type path with the Direct Selection tool . Then drag 
to adjust the shape of the path.  

Adjusting the type path using the Direct Selection tool is easiest when you’re in 
Outline view. 

 

Resizing a type area with the Direct Selection tool 

• Select the type object using the Selection tool or Layers panel, and choose Type > 
Area Type Options. Enter values for Width and Height, and click OK. If the text area 
is not a rectangle, these values determine the dimensions of the object’s bounding 
box. 



Change the margin around a text area 

When working with an area type object, you can control the margin between the text and the 
bounding path. This margin is referred to as the inset spacing. 

1. Select an area type object.  
2. Choose Type > Area Type Options. 
3. Specify a value for Inset Spacing, and click OK.  

 

Type without inset spacing (left) compared to type with inset spacing (right) 

Raise or lower the first baseline in a text area 

When working with an area type object, you can control the alignment of the first line of text 
with the top of the object. This alignment is referred to as the first baseline offset. For 
example, you can make text stick up above the top of the object or fall a specific distance 
below the top of the object. 

 
Type with First Baseline set to Cap Height (left) compared to type with First Baseline set to 
Leading (right) 
 



1. Select an area type object.  
2. Choose Type > Area Type Options. 
3. For First Baseline, choose one of the following options:  

Ascent 
The height of the “d” character falls below the top of the type object. 
Cap Height 
The tops of uppercase letters touch the top of the type object. 
Leading 
Uses the text’s leading value as the distance between the baseline of the first line of 
text and the top of the type object. 
x Height 
The height of the “x” character falls below the top of the type object. 
Em Box Height 
The top of the em box in Asian fonts touches the top of the type object. This option is 
available regardless of the Show Asian Options preference.  
Fixed 
Specifies the distance between the baseline of the first line of text and the top of the 
type object in the Min box. 
Legacy 
Uses the first baseline default used in Adobe Illustrator 10 or earlier. 

4. For Min, specify the value for the baseline offset.  

Create rows and columns of text 

1. Select an area type object. 
2. Choose Type > Area Type Options. 
3. In the Rows and Columns sections of the dialog box, set the following options:  

Number 
Specifies the number of rows and columns you want the object to contain. 
Span 
Specifies the height of individual rows and the width of individual columns.  
Fixed 
Determines what happens to the span of rows and columns if you resize the type 
area. When this option is selected, resizing the area can change the number of rows 
and columns, but not their width. Leave this option deselected if you want row and 
column widths to change when you resize the type area. 



 
Options for resizing rows and columns 
A. 
Original columns 
B. 
Columns resized with Fixed selected 
C. 
Columns resized with Fixed deselected 
Gutter 
Specifies the distance between rows or columns. 

4. In the Options section of the dialog box, select a Text Flow option to determine how 

text flows between rows and columns: By Rows  or By Columns .  
5. Click OK. 

Fit a headline across the full width of a type area 

1. Select a type tool, and click in the paragraph you want to fit across the type area. 
2. Choose Type > Fit Headline.  

Note: If you change the formatting of the type, be sure to reapply the Fit Headline 
command. 

Threading text between objects 

To thread (or continue) text from one object to the next, you link the objects. Linked type 
objects can be of any shape; however, the text must be entered in an area or along a path 
(not at a point). 

Each area type object contains an in port and an out port, which enable you to link to other 
objects and create a linked copy of the type object. An empty port indicates that all the text is 
visible and that the object isn’t linked. An arrow in a port indicates that the object is linked to 
another object. A red plus sign in an out port indicates that the object contains additional text. 
This remaining unseen text is called overflow text. 



 
Ports on linked type objects 

You can break threads and have the text flow into either the first or the next object, or you can 
remove all threads and have the text stay in place. 

Note: When working with threaded text, it can be useful to see the threads. To view threads, 
choose View > Show Text Threads and then select a linked object. 

Thread text 

1. Use the Selection tool to select an area type object. 
2. Click the in port or the out port of the selected type object. The pointer changes to the 

loaded text icon .  
3. Do one of the following: 

o To link to an existing object, position the pointer on the object’s path. The 

pointer changes to a . Click the path to link the objects. 
o To link to a new object, click or drag on an empty part of the artboard. 

Clicking creates an object of the same size and shape as the original; 
dragging lets you create a rectangular object of any size. 

Another method for threading text between objects is to select an area type 
object, select the object (or objects) you want to thread to, and then choose 
Type > Threaded Text > Create. 

Remove or break threads 

1. Select a linked type object. 
2. Do any of the following: 

o To break the thread between two objects, double-click the port on either end 
of the thread. The text flows into the first object. 

o To release an object from a text thread, choose Type > Threaded Text > 
Release Selection. The text flows into the next object. 

o To remove all threads, choose Type > Threaded Text > Remove Threading. 
The text stays in place. 

Wrap text around an object 



You can wrap area text around any object, including type objects, imported images, and 
objects you draw in Illustrator. If the wrap object is an embedded bitmap image, Illustrator 
wraps the text around opaque or partially opaque pixels and ignores fully transparent pixels.  

Wrapping is determined by the stacking order of objects, which you can view in the Layers 
panel by clicking the triangle next to the layer name. To wrap text around an object, the wrap 
object must be in the same layer as the text and located directly above the text in the layer 
hierarchy. You can drag contents up or down in the Layers panel to change hierarchy. 

 
Text wrapped around objects 
 
A. Wrap objects 
B. Wrapped text 

Wrap text 

1. Make sure that the following conditions are true for the type you want to wrap: 
o It is area type (typed in a box). 
o It is in the same layer as the wrap object.  
o It is located directly under the wrap object in the layer’s hierarchy.  

Important: If the layer contains multiple type objects, move any that you don’t want to 
wrap around the wrap object either into another layer or above the wrap object.  

2. Select the object or objects around which you want the text to wrap.  
3. Choose Object > Text Wrap > Make. 



Set wrap options 

You can set wrap options before or after you wrap the text. 

1. Select the wrap object. 
2. Choose Object > Text Wrap > Text Wrap Options and specify the following options:  

Offset 
Specifies the amount of space between the text and the wrap object. You can enter a 
positive or negative value. 
Invert Wrap 
Wraps the text around the reverse side of the object.  

Unwrap text from an object 

1. Select the wrap object.  
2. Choose Object > Text Wrap > Release. 

Align type to object 

To align text according to the bounding box of the actual glyphs instead of the font metrics, do 
the following:  

1. Apply the Outline Object live effect to the text object using Effect > Path > Outline 
Object. 

2. Set the Align panel to use preview bounds by selecting the Use Preview Bounds 
option from the Align panel menu (flyout). 

After applying these settings, you get exactly the same alignment as outlined text, while 
keeping the text live. 

Delete empty type objects from your artwork 

Deleting unused type objects makes your artwork easier to print and reduces the file size. 
You can create empty type objects, for example, if you inadvertently click the Type tool in the 
artwork area and then choose another tool.  

1. Choose Object > Path > Clean Up. 
2. Select Empty Text Paths, and click OK. 

 


